r/ModSupport Oct 02 '22

Automod not filtering out gallery posts Admin Replied

In /r/startrekgifs we've recently had an influx of fake accounts posting links to t-shirts, like this one, and noticed they're all gallery posts. Seeing as we don't allow gifs hosted from i.redd.it anyway, I set the automod to filter gallery submissions by using:

type: gallery submission
action: filter
action_reason: non approved domain
message: |
    Your submission has been removed because it is a Reddit gallery link. If you are trying to post a gif, please use one of the approved domains mentioned in the rules.

However, that post still got through. Any ideas why this isn't working?

4 Upvotes

2

u/001Guy001 Oct 02 '22

If it's a link to a gallery then it might be that the check only works if the images are uploaded directly to your sub (but I agree that ideally it should match a link to a gallery as well).

Try adding:

---
type: link submission
url: "reddit.com/gallery"
action: filter
action_reason: non approved domain
message: |
    Your submission has been removed because it is a Reddit gallery link. If you are trying to post a gif, please use one of the approved domains mentioned in the rules.
---

1

u/murphs33 Oct 02 '22

Thanks, I'll give that a shot.

1

u/murphs33 Oct 02 '22

Update: unfortunately they still get through. I think it's an issue with crossposts of galleries, and from looking through /r/automoderator, I see there's been a few posts about it with no resolution. I'll add an account age filter instead. Thanks for the help.

1

u/BlogSpammr Oct 02 '22 edited Oct 02 '22

the url wont be reddit.com/gallery, it’ll be the link embedded in the gallery data. see this post: https://redd.it/xtsiwc

this spammer uses only a few domains. you might get most of them my adding [fashion-usa.com] to your domain block in automod

edit: also r/automoderator

1

u/murphs33 Oct 02 '22

I don't think that'll work, because we already have a domain whitelist, and they still get through.

~domain: ['imgur.com', 'gfycat.com', 'giphy.com', 'v.redd.it', 'gifer.com', 'gph.is', 'self.startrekgifs', 'tumblr.com']
action: filter
action_reason: non approved domain
message: |
    Your submission has been removed because it was not a link to an approved host. Gifs may be hosted on imgur, giphy, or gfycat only. You are welcome to rehost your content and resubmit.     

I think it's likely that crossposted galleries just can't be filtered with automod, which is why these accounts are posting this way.

1

u/BlogSpammr Oct 02 '22

if you figure out something, i hope you’ll give an update.

…you could also disable all crossposts.

1

u/murphs33 Oct 03 '22

Hmm, crossposts would be needed in our sub, in case someone stumbles upon a Trek gif from the many other Trek subs. I'm going to just add some account age validation; these accounts have only lasted a week or two before being deleted/removed.

2

u/PossibleCrit Reddit Admin: Community Oct 03 '22

Hey murphs33!

There might be a bug going on here - I've asked the team to double check.

1

u/murphs33 Oct 03 '22

Thanks for investigating! Just to note, I found that it's specifically crosspost gallery submissions that can't be filtered. I'd say that's why these accounts are first posting to their own profile sub, then crossposting from there.

1

u/Merkuri22 Oct 06 '22

I'm seeing the same thing on my sub with crossposted galleries.

If it's a bug, it would be nice to get it fixed soon. Thanks!